If you are unsure, try just installing TestCaddy as it will tell you if .NET 2.0 or MSI 3.1 is missing from your system. Likewise asking TestCaddy to install SQL Express will tell you if you are missing .NET 3.5.1 or MSI 4.5. The installer can optionally install these missing pre-requisites for you if you wish. For further details on the pre-requisites refer to the Installation Detail page.